Singapore datacenter statistics delay
Incident Report for EXADS
Resolved
All statistics have caught up.
Posted Mar 05, 2024 - 17:33 UTC
Investigating
We are experiencing network issues with Internet transit providers connecting Asia, and our Singapore datacenter's statistics are being delayed.
Posted Mar 05, 2024 - 16:46 UTC
This incident affected: Statistics.