Ad-Serving issues

Incident Report for EXADS

Resolved

This incident has been resolved.
Posted Mar 23, 2025 - 15:34 UTC

Investigating

We are experiencing some ad-serving issues with USA Publisher RTB traffic, and are looking into it.
Posted Mar 23, 2025 - 15:17 UTC
This incident affected: Ad Serving.